WeMod Steam Deck video tutorial

I don’t have much experience recording videos, and I’ve never used video editing software before, but due to popular demand, and since i had the Decky Recorder plugin anyway, decided to make a video as a companion to my Imgur tutorial. Brutal Legend was a good choice because I got to show one of the bugs in Game Mode that I’ve only experienced with a few games, where when switching windows, upon returning to the game the screen shrinks and becomes unplayable. Those games are the ones where the WeMod app is essential. Once you connect it once, the app will automatically reconnect regardless of which prefix you’re using. The cheats were deactivating the first time i ran it after installing it to Brutal Legend so i also got a chance to show the first troubleshooting solution to try whenever any problems arise, by deleting the WeMod folder in Roaming.


Thank you for this, you’re the only person I’ve found that is explaining any of this. However, when I try to watch the video it says it’s private.

1 Like

I was able to access it earlier. Looks like they privated it. Possibly editing some info, or taking it down and re-uploading

1 Like

Sounds good, thanks

Its back up, yeah i needed to make an edit

1 Like

i just needed to trim a few extra seconds, its good now. I’m just glad YouTube has trimming tools, was worried I’d have to delete it and reupload. YouTube’s tools were easier than any of the video editors i found on the Discover Store.

1 Like

And I’m kinda sad that there doesn’t seem to be more experienced Linux vets in this community. Never used Linux until i got my Steam Deck, so while my way isn’t too difficult or anything, I’m sure someone more experienced would be able to figure out a faster way.

1 Like

Realistically, people don’t wanna take the time to learn. I have a decent understanding but since I noticed you had made a video I’d rather watch that to make sure I don’t screw anything up.

1 Like

I appreciate the effort Valve put into SteamOS so I am riding with them to the end with it. But i like to tinker and mod, so i spent my first month with my Deck just teaching myself the basics of Linux so i could learn to do everything on Linux I’d normally do on Windows. And idk, i also feel a sense of pride and accomplishment when I figure something out. I’m a truck driver, i am computer literate, but ain’t an expert or anything.

My presumption is that people should at least have an awareness of the basics like ProtonUp-Qt, and Steam Tinker Launch. Even if you don’t intend to learn much, those are such supremely useful tools, that they should be on the list of every new Deck owner. And i walk through what you need to do, so they don’t need to really understand all of it. I got STL first for Vortex, but over time just played around and figured out more things. Like there’s literally half a dozen entirely different ways to install DotNet Framework and WeMod just inside STL alone.

Hi @BrandonKingM

Thanks for the video and tutorial! It’s fantastic. Anyone unable to follow should really do some little bit of homework.

I’m having an installation failure on the .net framework. Was wondering if you would know why.

Launched steam tinker launch and switched to windows 7. Selected the .net file downloaded earlier from the link you provided. It starts the install and then just fails.

Didn’t give me any specific error. Just says “Installation did not succeed” and “Installation Failure”.

Any ideas? Have you come across it?

1 Like

Try changing your starting Proton version. For example, earlier today i first tried 7.0.6 with Left 4 Dead 2, i got that error but changing it to Proton GE 7-54 fixed it and it installed properly. You could also try installing it a few different ways like through One Time Run, as a custom command in STL with Use Only Custom Command checked, or ProtonTricks. I prefer first trying to install from Winetricks uninstall because other than ProtonTricks the other ways don’t add WeMod and DotNet to the list of installed programs. I like seeing it there, but its not mandatory. Sorry for late reply, i only check the forums once or twice a week.

So, I’ve followed the instructions on the video guide and got the dotnet framework 4.8 installed without any issues. I then switched the proton version to 6-19-GE2 as instructed and did another one time run of the Uninstaller to install Wemod (WeMod-8.9.0.exe) but nothing happens. I wait for a long time but the Wemod installation screen never pops up and nothing gets installed. I’ve made sure that the winecfg is set to Windows 7 the entire time. Anything else I should try or is this an issue with the WeMod-8.9.0.exe?

1 Like

Yeah, there is a WeMod installer/launcher now for Linux you can use, but the DotNet install doesn’t always work right so if you want to use it and the DotNet install errors out you can add a blank file named .wemod_installer to the prefix right next to the drive_c folder that tells the launcher to ignore the DotNet installer part. Or if you like the Steam Tinker Launch method, the way the launcher handles WeMod makes the STL method a lot quicker, you can either run the launcher just for the WeMod install, or use 7zip to extract the wemod_bin folder from inside the WeMod installer exe. The launcher automatically extracts it for you. Then go to STL, install DotNet per my tutorial, and then rather then installing WeMod to the prefix, go to Game Mode, and select the WeMod.exe from the wemod_bin folder as your custom command.