My perfected and streamlined WeMod tutorial for Steam Deck

My first tutorial was functional but tedious and included a lot of unnecessary steps as i was still figuring things out myself. Half the steps from that tutorial were the DotNet rabbit hole Winetricks forces you down.

Download the DotNet Framework 4.8 installer from here:

Download the WeMod offline installer from here:

https://api.wemod.com/client/download 2.2k

Here are the screenshots detailing the tutorial step by step:

https://imgur.com/gallery/BElRnD9

I have tested this method on nearly 30 games, and it works universally. It can all be done in Game Mode, and once you have the steps down, it is surprisingly very quick

3 Likes

If you corrupt your prefix, or run into any errors upon launching WeMod, just delete the prefix and start over. The errors usually work themselves out on a fresh reinstall. I suggest getting the prefix setup with the Proton you’ll be playing with because the main cause of corrupt prefixes with WeMod seems to be changing your Proton version after its installed.

Pro is pretty much mandatory for Steam Deck because a lot of games will crash when switching between the game and WeMod, and many more games disable all input on WeMod, so i heavily rely on the mobile app to use WeMod on Deck. The good thing is, regardless of prefix, once you connect your phone, it will work on every single WeMod installation in every prefix automatically.

Idk if this is a WeMod issue or a Steam Deck issue, but the entire Assassins Creed series only works with the Ubisoft trainers, not the Steam trainers. I thought it had to do with Ubisoft Connect but Watch Dogs and Watch Dogs 2 work with the Steam trainers despite also having Ubisoft Connect

Thank you for your work.

It would still be much easier to have a portable “lite” Wemod Client. It could still be windows based and without an interface, so it would be pro-only with mobile app access.

2 Likes

Hey, I appreciate the streamlined version of your tutorial (I saw your original one on Reddit) but it does seem to be missing some detail for beginners. I’m brand new to Linux gaming so I don’t really understand prefixes, Proton, Wine, Steam Tinker Launcher, etc.

It would be nice for you to explain what these are and how they contribute to getting games with WeMod to work.

For example I got confused in just the first step:

Start with a fresh prefix and figure out what version of Proton you will be ending with. Do the initial prefix setup with that version of Proton.

What does start with a fresh prefix mean? What do you mean by what version we will be ending with? What does doing the initial prefix setup entail, or is that what comes next in the tutorial?

This wasn’t very clear to me.

Also, I got confused (but eventually figured it out by reading more of the tutorial) about why you say to download .NET and WeMod first but don’t mention installing.

I do really appreciate that you’ve put so much time into figuring this out and providing your findings to all of us who want to mod games on the Steam Deck. I’ll keep working on trying to follow the tutorial.

1 Like

It is still confusing to me, I’m really new to Linux, is it possible to make a video tutorial?

1 Like

So the prefix is the compartmentalized Windows environment your game exists in. For Steam its in the Compatdata folder. They are organized by the Steam AppID. If you’re on Steam Deck, go to desktop mode, the Discover store, and type in ProtonUp-Qt, from that app you can download Steam Tinker Launch. Its a compatibility tool built on top of Proton with all kinds of tools and features. You activate it by going to a game, Properties, Compatibility and selecting Steam Tinker Launch from the dropdown menu

I wish i could, but unless i take it with my phone, idk how. I’m not very tech savvy. Just had my Deck since May and spent the first month learning the basics of Linux and been learning as i go since. I’d say learn the basics first before you jump into stuff like this. Download ProtonUp-Qt from the Discover store, download Steam Tinker Launch from it, and first get familiar and comfortable with it because its an endlessly useful tool. I first got it for Vortex mod manager, but over time I learned how to use more of its features. Like my previous posts about WeMod used multiple tools, but i figured out how to do everything you need from what STL provides

Learning how STL works will make my instructions make a lot more sense. And the cool thing about Linux is if you ■■■■ up, you can always delete the prefix and start again

The installers install where its supposed to. The important part is installing them in the game’s prefix, it’ll do its job from there

And my assumption is that you know what Steam Tinker Launch is, this isn’t advanced stuff, but its definitely not for fresh to Linux novices either. I’ve never used Linux before i got my Steam Deck, but i spent my whole first month teaching myself the basics like Steam Tinker Launch so that i can learn to do anything on Deck that I’d do on Windows. This is just a tutorial for installing WeMod, there is a million tutorials on STL and ProtonUp-Qt.

Dear Brandon, thank you very much for your tutorial! It has helped me a lot.
However, I am now facing a problem.

After I installed Net I should install WeMod but I get the error message:

Error 1:
Installation Failed.

Please re-run this installer as a normal user instead of “Run as
Administrator”.

OR

Error 2:
„Your Computer appears to be offline….“

Do you have a solution for this?
Greetings

2 Likes

I’m also having the issue noteric mentioned. I’ve tried tons of things and nothing seems to work. I abandoned the effort because of this. I hope someone can find a solution

@iAmNotEric Im getting the same error….


@BrandonKingM, is there any way you can do a step by step video tutorial? I we all would appreciate that.


@TinMaus Can you explain how you got it working?


@BrandonKingM
I kinda of figured out but not I’m having issues when I’m installing Framework 4.8 …. Any advice?

1 Like

Hey so I have basically no idea what I’m doing but I’ve gone through all the steps and, as far as I know, I haven’t missed anything or messed anything up but I still can’t get this to work. I got wemod installed, I’ve installed the .net framework 4.8, but wemod constantly tells me I have the incorrect .net framework version installed. It makes no sense. I don’t know if it helps but whenever I try to re-install the framework it says I already have it installed, but it doesn’t show up on the list next wemod on the uninstaller…which is confusing. Anybody else having this problem?

1 Like

For most errors reinstalling or deleting the WeMod folder from Roaming will fix it, but if you are getting the run installer as normal user, and you are using Proton-6.19-GE-2 then my suggestion would be to go to Winetricks, go to Regedit, then follow the chain down from HKEY_LOCAL_MACHINE/Software/Microsoft/Windows/Policies/System in System click EnableLUA, turn it from 0 to 1. If that doesn’t work then idk what to tell ya, because the only reason that should be happening is if your using Proton 7+ because the earlier Proton versions handled UAC much differently. In 7+, its built in with no way to disable it. The EnableLUA thing in the registry should disable it in Proton GE 6. Not sure how it works exactly, but while trying to figure this out i came across that helpful little tidbit of knowledge. For some reason I don’t always need to do it, but if i get that error then i do.

Yea so im with most of the other people here. You skipped some of the most important steps to a tutorial. Ie the entire installation. Which some of us cant figure out and dont understand what we are missing bc of your lack of explanation.

With that being said, i am very greatful in your efforts, its just absolutely useless to anyone just getting started.

1 Like

Download ProtonUp-Qt from the Discover store, click the Proton GE dropdown menu, and select Steam Tinker Launch, install the latest version. Then restart Steam, go to a game, click Properties, Compatibility and then tick the checkbox and select Steam Tinker Launch from the Proton list. Its a compatibility layer built on top of Proton with all kinds of useful tools, including downloading, installing and managing Vortex mod manager if you’re into modding Bethesda games. I wouldn’t say you need to be experienced with Linux for this tutorial, or even intermediary, but it definitely isn’t for Day One SteamOS users. My presumption is that people should know the basics before even reaching this point. Steam Tinker Launch is one of the greatest tools you’ll ever need on Deck

I don’t even consider myself to have an intermediary level of skill with Linux. I’m more experienced than a beginner, but not by much. I just excel at copy and paste, with borderline reckless trial and error. I have had to reimage my Deck SO MANY times because I’m tinkering with things i barely understand and then break something fundamental to the operating system. Literally while trying to get WeMod working, had to reimage my Deck twice when a couple of my theories wildly messed up the file system experimenting with things way outside my depth that I thought might work.