Error message upon trying to open

all i get when i try to open the program and all i get is an error message saying “Failed to connect to servers!”

post a picture of the screenshot.

well i figured it out i had to use the command prompt to find the files and i had to delete a file folder then had to re download it

I still have this problem how can I fix it

you’re gonna have to open your file explorer

then you’ll have to go to %appdata% like so


It will bring you to this page and youll have to click on the highlited area


Then you’ll have to click on the local for the final step

1 Like

Then delete the higlited Daring development inc folder and re-download the program and it should work


You shouldnt even have to do that, did you not check that your anti-viruses firewall wasn’t blocking Horizon from connecting to the servers?

More than likely that would be the problem/fix.

considering that i already checked all that and downloaded all the stuff that people said would make it work and that it still didnt work im fine with the way i did it because it worked and its not like its hurting anything and i dont have to download a bunch of crap that didnt work anyway to save space on the computer plus its so much faster then downloading it and much safer then shutting off your protection

also thats right it wasnt blocking it it wasnt working at all the program as a whole stalled and just kinda quit but its working again so im pretty sure that the method that i used is one of the easiest

thanks you that help me

Try this:
Here is what I did: I first made an exeption for Horizon in my Win Firewall…I allowed it to run.
Next, I disabled Win Firewall for a while, ran Horizon which was GreaTTT.
Finally, I activated my firewall and checked if HOzHOz still worked…and guess what happened! HOzHOz is GreaTTTTTT

This worked perfectly, I was having so many issues and this solved it, thanks so much DiamondM0dder.

I tried allowing the app through the firewall, disabling anti-virus, nothing worked. I deleted that folder, and boom, everything worked, thanks again!

same here

I don’t have that folder, probably because Horizon can’t run and never ran on my system

Horizon isn’t installed to appdata anymore. It is in program files x86 > Daring Development

Please create a new thread. This one is almost a year old.